关于中文ID注册的支持?(已经做好了,看35楼插件版)

中文

(神楽坂玲奈) #41

记一下现在的字符范围

CJK Unified Ideographs blocks 4E00-9FD5
CJK Unified Ideographs Extension A 3400-4DBF
CJK Unified Ideographs Extension B 20000-2A6DF
CJK Unified Ideographs Extension C 2A700-2B73F
CJK Unified Ideographs Extension D 2B740–2B81F
CJK Unified Ideographs Extension E 2B820–2CEAF

CJK Compatibility Ideographs F900–FAFF
CJK Compatibility Ideographs Supplement 2F800-2FA1D

Hangul Syllables AC00–D7AF

Hiragana 3040–309F
Katakana 30A0–30FF
Katakana Phonetic Extensions 31F0–31FF
Kana Supplement 1B000–1B0FF

特殊 \u3005

正则表达式
\u4E00-\u9FD5\u3400-\u4DBF\u{20000}-\u{2A6DF}\u{2A700}-\u{2CEAF}\uF900–\uFAFF\u{2F800}-\u{2FA1D}\uAC00–\uD7AF\u3040-\u30FF\u31F0–\u31FF\u{1B000}–\u{1B0FF}\u3005


(石头) #42

好赞。。。下午有空我试试。。谢兄弟。。


(石头) #43

没成功。。求助,该怎么办?@zh99998

root@iZ23vsqqkmsZ:/mnt/discourse# ./launcher rebuild app
Ensuring discourse docker is up to date
Fetching origin
fatal: unable to access ‘https://github.com/discourse/discourse_docker.git/’: Could not resolve host: github.com
error: Could not fetch origin
Discourse Docker is up-to-date
Stopping old container

  • /usr/bin/docker stop -t 10 app
    app
    cd /pups && git pull && /pups/bin/pups --stdin
    fatal: unable to access ‘https://github.com/SamSaffron/pups.git/’: Could not resolve host: github.com
    daae16cda55fa56800e1122c3def2f67f5643e92362cb46bb8ab95a42a933c3c
    ** FAILED TO BOOTSTRAP ** please scroll up and look for earlier error messages, there may be more than one

(神楽坂玲奈) #44

这说的很明白了。。试着改一下服务器 DNS 吧


(石头) #45

咋改啊???命令怎么输入:smile:


(石头) #46

0: byebug (5.0.0) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/byebug-5.0.0.gemspec
Installing timers 4.0.1
0: timers (4.0.1) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/timers-4.0.1.gemspec
Using sprockets 2.11.0
0: sprockets (2.11.0) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/sprockets-2.11.0.gemspec
Installing thin 1.6.3 with native extensions
Building native extensions. This could take a while…
0: thin (1.6.3) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/thin-1.6.3.gemspec
Using faraday 0.9.1
0: faraday (0.9.1) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/faraday-0.9.1.gemspec
Using rb-inotify 0.9.5
0: rb-inotify (0.9.5) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/rb-inotify-0.9.5.gemspec
Using given_core 3.5.4
0: given_core (3.5.4) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/given_core-3.5.4.gemspec
Using omniauth 1.2.2
0: omniauth (1.2.2) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/omniauth-1.2.2.gemspec
Using image_optim 0.20.2
0: image_optim (0.20.2) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/image_optim-0.20.2.gemspec
Using message_bus 1.0.16
0: message_bus (1.0.16) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/message_bus-1.0.16.gemspec
Using redis-namespace 1.5.2
0: redis-namespace (1.5.2) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/redis-namespace-1.5.2.gemspec
Using mocha 1.1.0
0: mocha (1.1.0) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/mocha-1.1.0.gemspec
Using nokogiri 1.6.6.2
0: nokogiri (1.6.6.2) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/nokogiri-1.6.6.2.gemspec
Using rest-client 1.7.2
0: rest-client (1.7.2) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/rest-client-1.7.2.gemspec
Using rack-openid 1.3.1
0: rack-openid (1.3.1) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/rack-openid-1.3.1.gemspec
Using openid-redis-store 0.0.2
0: openid-redis-store (0.0.2) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/openid-redis-store-0.0.2.gemspec
Using pry 0.10.1
0: pry (0.10.1) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/pry-0.10.1.gemspec
Installing unicorn 4.8.3 with native extensions
Building native extensions. This could take a while…
0: unicorn (4.8.3) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/unicorn-4.8.3.gemspec
Using rbtrace 0.4.7
0: rbtrace (0.4.7) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/rbtrace-0.4.7.gemspec
Using therubyracer 0.12.2
0: therubyracer (0.12.2) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/therubyracer-0.12.2.gemspec
Using rspec-core 3.2.3
0: rspec-core (3.2.3) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/rspec-core-3.2.3.gemspec
Using rspec-expectations 3.2.1
0: rspec-expectations (3.2.1) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/rspec-expectations-3.2.1.gemspec
Using rspec-mocks 3.2.1
0: rspec-mocks (3.2.1) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/rspec-mocks-3.2.1.gemspec
Installing simplecov 0.9.1
0: simplecov (0.9.1) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/simplecov-0.9.1.gemspec
Using unf 0.1.4
0: unf (0.1.4) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/unf-0.1.4.gemspec
Using fast_stack 0.1.0
0: fast_stack (0.1.0) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/fast_stack-0.1.0.gemspec
Using fast_xor 1.1.3
0: fast_xor (1.1.3) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/fast_xor-1.1.3.gemspec
Installing activesupport 4.1.10
0: activesupport (4.1.10) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/activesupport-4.1.10.gemspec
Installing sinatra 1.4.5
0: sinatra (1.4.5) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/sinatra-1.4.5.gemspec
Installing mail 2.5.4
0: mail (2.5.4) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/mail-2.5.4.gemspec
Installing aws-sdk-core 2.0.45
0: aws-sdk-core (2.0.45) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/aws-sdk-core-2.0.45.gemspec
Installing celluloid 0.16.0
0: celluloid (0.16.0) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/celluloid-0.16.0.gemspec
Using ember-handlebars-template 0.1.5
0: ember-handlebars-template (0.1.5) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/ember-handlebars-template-0.1.5.gemspec
Using oauth2 1.0.0
0: oauth2 (1.0.0) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/oauth2-1.0.0.gemspec
Installing omniauth-oauth 1.0.1
0: omniauth-oauth (1.0.1) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/omniauth-oauth-1.0.1.gemspec
Installing nokogumbo 1.2.0 with native extensions
Building native extensions. This could take a while…
0: nokogumbo (1.2.0) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/nokogumbo-1.2.0.gemspec
Installing onebox 1.5.26
0: onebox (1.5.26) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/onebox-1.5.26.gemspec
Using ruby-readability 0.7.0
0: ruby-readability (0.7.0) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/ruby-readability-0.7.0.gemspec
Using omniauth-openid 1.0.1
0: omniauth-openid (1.0.1) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/omniauth-openid-1.0.1.gemspec
Using pry-nav 0.2.4
0: pry-nav (0.2.4) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/pry-nav-0.2.4.gemspec
Installing pry-rails 0.3.3
0: pry-rails (0.3.3) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/pry-rails-0.3.3.gemspec
Using rspec 3.2.0
0: rspec (3.2.0) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/rspec-3.2.0.gemspec
Using flamegraph 0.1.0
0: flamegraph (0.1.0) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/flamegraph-0.1.0.gemspec
Installing actionview 4.1.10
0: actionview (4.1.10) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/actionview-4.1.10.gemspec
Installing activemodel 4.1.10
0: activemodel (4.1.10) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/activemodel-4.1.10.gemspec
Using shoulda-matchers 2.7.0
0: shoulda-matchers (2.7.0) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/shoulda-matchers-2.7.0.gemspec
Installing aws-sdk-resources 2.0.45
0: aws-sdk-resources (2.0.45) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/aws-sdk-resources-2.0.45.gemspec
Installing sidekiq 3.4.2
0: sidekiq (3.4.2) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/sidekiq-3.4.2.gemspec
Installing omniauth-oauth2 1.2.0
0: omniauth-oauth2 (1.2.0) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/omniauth-oauth2-1.2.0.gemspec
Installing omniauth-twitter 1.0.1
0: omniauth-twitter (1.0.1) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/omniauth-twitter-1.0.1.gemspec
Installing sanitize 3.1.2
0: sanitize (3.1.2) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/sanitize-3.1.2.gemspec
Using rspec-given 3.5.4
0: rspec-given (3.5.4) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/rspec-given-3.5.4.gemspec
Installing actionpack 4.1.10
0: actionpack (4.1.10) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/actionpack-4.1.10.gemspec
Using active_model_serializers 0.8.3
0: active_model_serializers (0.8.3) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/active_model_serializers-0.8.3.gemspec
Installing activerecord 4.1.10
0: activerecord (4.1.10) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/activerecord-4.1.10.gemspec
Using rails-observers 0.1.2
0: rails-observers (0.1.2) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/rails-observers-0.1.2.gemspec
Using shoulda 3.5.0
0: shoulda (3.5.0) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/shoulda-3.5.0.gemspec
Installing aws-sdk 2.0.45
0: aws-sdk (2.0.45) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/aws-sdk-2.0.45.gemspec
Using sidekiq-statistic 1.1.0
0: sidekiq-statistic (1.1.0) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/sidekiq-statistic-1.1.0.gemspec
Installing omniauth-facebook 2.0.0
0: omniauth-facebook (2.0.0) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/omniauth-facebook-2.0.0.gemspec
Using omniauth-github-discourse 1.1.2
0: omniauth-github-discourse (1.1.2) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/omniauth-github-discourse-1.1.2.gemspec
Using omniauth-google-oauth2 0.2.5
0: omniauth-google-oauth2 (0.2.5) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/omniauth-google-oauth2-0.2.5.gemspec
Installing actionmailer 4.1.10
0: actionmailer (4.1.10) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/actionmailer-4.1.10.gemspec
Installing railties 4.1.10
0: railties (4.1.10) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/railties-4.1.10.gemspec
Using sprockets-rails 2.0.1
0: sprockets-rails (2.0.1) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/sprockets-rails-2.0.1.gemspec
Using seed-fu 2.3.5
0: seed-fu (2.3.5) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/seed-fu-2.3.5.gemspec
Using discourse-qunit-rails 0.0.8
0: discourse-qunit-rails (0.0.8) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/discourse-qunit-rails-0.0.8.gemspec
Using jquery-rails 3.1.2
0: jquery-rails (3.1.2) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/jquery-rails-3.1.2.gemspec
Using rspec-rails 3.2.1
0: rspec-rails (3.2.1) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/rspec-rails-3.2.1.gemspec
Installing rails 4.1.10
0: rails (4.1.10) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/rails-4.1.10.gemspec
Using sass-rails 4.0.5
0: sass-rails (4.0.5) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/sass-rails-4.0.5.gemspec
Using ember-rails 0.18.2
0: ember-rails (0.18.2) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/ember-rails-0.18.2.gemspec
Using spork-rails 4.0.0
0: spork-rails (4.0.0) from /var/www/discourse/vendor/bundle/ruby/2.0.0/specifications/spork-rails-4.0.0.gemspec
Bundle complete! 92 Gemfile dependencies, 173 gems now installed.
Gems in the group development were not installed.
Bundled gems are installed into ./vendor/bundle.

I, [2016-01-14T12:49:11.105934 #38] INFO – : > cd /var/www/discourse && su discourse -c ‘bundle exec rake db:migrate’
2016-01-14 12:50:18 UTC [4353-1] discourse@discourse LOG: duration: 215.399 ms statement: SELECT oid, typname, typelem, typdelim, typinput FROM pg_type
195:M 14 Jan 12:50:19.178 * 10 changes in 300 seconds. Saving…
195:M 14 Jan 12:50:19.180 * Background saving started by pid 4354
4354:C 14 Jan 12:50:19.401 * DB saved on disk
4354:C 14 Jan 12:50:19.402 * RDB: 18 MB of memory used by copy-on-write
195:M 14 Jan 12:50:19.480 * Background saving terminated with success
rake aborted!
NameError: uninitialized constant LetterAvatar::Identity
/var/www/discourse/plugins/discourse-username-localization/plugin.rb:52:in block in activate!' /var/www/discourse/lib/plugin/instance.rb:176:incall’
/var/www/discourse/lib/plugin/instance.rb:176:in block in notify_after_initialize' /var/www/discourse/lib/plugin/instance.rb:174:ineach’
/var/www/discourse/lib/plugin/instance.rb:174:in notify_after_initialize' /var/www/discourse/config/application.rb:176:inblock (2 levels) in class:Application
/var/www/discourse/config/application.rb:176:in each' /var/www/discourse/config/application.rb:176:inblock in class:Application
/var/www/discourse/vendor/bundle/ruby/2.0.0/gems/activesupport-4.1.10/lib/active_support/lazy_load_hooks.rb:36:in call' /var/www/discourse/vendor/bundle/ruby/2.0.0/gems/activesupport-4.1.10/lib/active_support/lazy_load_hooks.rb:36:inexecute_hook’
/var/www/discourse/vendor/bundle/ruby/2.0.0/gems/activesupport-4.1.10/lib/active_support/lazy_load_hooks.rb:45:in block in run_load_hooks' /var/www/discourse/vendor/bundle/ruby/2.0.0/gems/activesupport-4.1.10/lib/active_support/lazy_load_hooks.rb:44:ineach’
/var/www/discourse/vendor/bundle/ruby/2.0.0/gems/activesupport-4.1.10/lib/active_support/lazy_load_hooks.rb:44:in run_load_hooks' /var/www/discourse/vendor/bundle/ruby/2.0.0/gems/railties-4.1.10/lib/rails/application/finisher.rb:64:inblock in module:Finisher
/var/www/discourse/vendor/bundle/ruby/2.0.0/gems/railties-4.1.10/lib/rails/initializable.rb:30:in instance_exec' /var/www/discourse/vendor/bundle/ruby/2.0.0/gems/railties-4.1.10/lib/rails/initializable.rb:30:inrun’
/var/www/discourse/vendor/bundle/ruby/2.0.0/gems/railties-4.1.10/lib/rails/initializable.rb:55:in block in run_initializers' /var/www/discourse/vendor/bundle/ruby/2.0.0/gems/railties-4.1.10/lib/rails/initializable.rb:54:inrun_initializers’
/var/www/discourse/vendor/bundle/ruby/2.0.0/gems/railties-4.1.10/lib/rails/application.rb:300:in initialize!' /var/www/discourse/vendor/bundle/ruby/2.0.0/gems/railties-4.1.10/lib/rails/railtie.rb:194:inpublic_send’
/var/www/discourse/vendor/bundle/ruby/2.0.0/gems/railties-4.1.10/lib/rails/railtie.rb:194:in method_missing' /var/www/discourse/config/environment.rb:5:in<top (required)>’
/var/www/discourse/vendor/bundle/ruby/2.0.0/gems/railties-4.1.10/lib/rails/application.rb:276:in require_environment!' /var/www/discourse/vendor/bundle/ruby/2.0.0/gems/railties-4.1.10/lib/rails/application.rb:405:inblock in run_tasks_blocks’
Tasks: TOP => db:migrate => environment
(See full trace by running task with --trace)
I, [2016-01-14T12:50:21.280756 #38] INFO – : gem install chinese_pinyin -v 1.0.0 -i /var/www/discourse/plugins/discourse-username-localization/gems/2.0.0 --no-document --ignore-dependencies
Successfully installed chinese_pinyin-1.0.0
1 gem installed
gem install romaji -v 0.2.3 -i /var/www/discourse/plugins/discourse-username-localization/gems/2.0.0 --no-document --ignore-dependencies
Successfully installed romaji-0.2.3
1 gem installed

I, [2016-01-14T12:50:21.281811 #38] INFO – : Terminating async processes
I, [2016-01-14T12:50:21.282098 #38] INFO – : Sending INT to HOME=/var/lib/postgresql USER=postgres exec chpst -u postgres:postgres:ssl-cert -U postgres:postgres:ssl-cert /usr/lib/postgresql/9.3/bin/postmaster -D /etc/postgresql/9.3/main pid: 67
2016-01-14 12:50:21 UTC [67-2] LOG: received fast shutdown request
2016-01-14 12:50:21 UTC [67-3] LOG: aborting any active transactions
2016-01-14 12:50:21 UTC [74-2] LOG: autovacuum launcher shutting down
2016-01-14 12:50:21 UTC [71-1] LOG: shutting down
I, [2016-01-14T12:50:21.286908 #38] INFO – : Sending TERM to exec chpst -u redis -U redis /usr/bin/redis-server /etc/redis/redis.conf pid: 195
195:signal-handler (1452775821) Received SIGTERM scheduling shutdown…
2016-01-14 12:50:21 UTC [71-2] LOG: database system is shut down
195:M 14 Jan 12:50:21.385 # User requested shutdown…
195:M 14 Jan 12:50:21.385 * Saving the final RDB snapshot before exiting.
195:M 14 Jan 12:50:21.568 * DB saved on disk
195:M 14 Jan 12:50:21.569 # Redis is now ready to exit, bye bye…

FAILED

RuntimeError: cd /var/www/discourse && su discourse -c ‘bundle exec rake db:migrate’ failed with return #<Process::Status: pid 4331 exit 1>
Location of failure: /pups/lib/pups/exec_command.rb:105:in `spawn’
exec failed with the params {“cd”=>"$home", “hook”=>“bundle_exec”, “cmd”=>[“su discourse -c ‘bundle install --deployment --verbose --without test --without development’”, “su discourse -c ‘bundle exec rake db:migrate’”, “su discourse -c ‘bundle exec rake assets:precompile’”]}
2f800f5f2ea7625120d5c2fadab43e5d3aea6b8e97bfc377da990411ebd5374e
** FAILED TO BOOTSTRAP ** please scroll up and look for earlier error messages, there may be more than one
root@iZ23vsqqkmsZ:/mnt/discourse#


加入插件

./launcher rebuild app 后一直这样,怎么办??


(神楽坂玲奈) #47

我没有遇到过这个问题…
我这里用的discourse 版本是默认的 tested-pass,你也是么?


(freemangl) #48

看到这行就基本可以确定是网络被墙的问题了,要不加代理/VPN,要不用国外服务器。
我从@zh99998发布插件版后就想重装,在docker下运行转换脚本,目前还卡在这里呢…


(石头) #49

请问下。。代理怎么加呢?


(freemangl) #50

我折腾了3天了,已经放弃加代理和VPN,我买了国外的服务器了…

如何加请自行搜索。


(freemangl) #51

你是不是加了QQ登陆插件?好像是这个引起的问题,删掉试试。


(神楽坂玲奈) #52

更新:

修正中文用户头像点击弹不出个人卡片的问题
修正中文分类名称在发帖时用 #xx 无法识别的问题
在设置用户名使用了不允许的字符时,提示的里面加入中文


(石头) #53



安装中文插件,./launcher rebuild app失败后,找到这几行带“ERROR”的错误提示,不知道要怎么办了,求助。@zh99998 @fantasticfears


(石头) #54

再次./launcher rebuild app后发现以下错误。。该怎么解决?大神请赐教,,@zh99998 @fantasticfears

I, [2016-01-19T02:27:51.568855 #37] INFO – : > su postgres -c ‘createdb discourse’ || true
2016-01-19 02:27:51 UTC [78-1] postgres@postgres ERROR: database “discourse” already exists
2016-01-19 02:27:51 UTC [78-2] postgres@postgres STATEMENT: CREATE DATABASE discourse;

createdb: database creation failed: ERROR: database “discourse” already exists
I, [2016-01-19T02:27:51.641191 #37] INFO – :
I, [2016-01-19T02:27:51.642541 #37] INFO – : > su postgres -c ‘psql discourse -c “create user discourse;”’ || true
2016-01-19 02:27:51 UTC [89-1] postgres@discourse ERROR: role “discourse” already exists
2016-01-19 02:27:51 UTC [89-2] postgres@discourse STATEMENT: create user discourse;
ERROR: role “discourse” already exists
I, [2016-01-19T02:27:51.731014 #37] INFO – :


(神楽坂玲奈) #55

第一次是我的 shell 脚本执行失败了,不知道什么情况。
@fantasticfears 有什么想法么

第二次数据库已存在。。如果现在里面没有东西的话就简单把数据库文件干掉吧。


(石头) #56

怎么干掉?
网站已经有不少用户和文章了。。。


(神楽坂玲奈) #57

那不明。。我执行的时候如果网站已经有数据,rebuild 就不会尝试创建新角色了…


(石头) #58

那我该怎么办呢?


(freemangl) #59

这个是被墙了…和你第一次的错误一样。


(石头) #60

那数据库错误那个有办法解决吗?