1.42升1.43不成功求助。

@fantasticfears
如题点击升级后出现这串提示,按照提示
输入
cd /var/discourse
git pull
./launcher rebuild app
命令行后,结果还是一样。。

You are running an old version of the Discourse image.

Upgrades via the web UI are disabled until you run the latest image.

To do so log in to your server using SSH and run:

cd /var/discourse
git pull
./launcher rebuild app
More info on our support site

你需要用 ssh 进入你的服务器,进去之后执行这 3 个命令。如果有错误的话,是什么错误呢?

如果是大陆地区的网络错误,只能麻烦你多重试几次了。

提示是这样的,好像是 Docker的版本不够,,但上面git pull 提示已经是最新版本了啊???

git pull 的不是 Docker,是 Discourse 的 Docker 文件。你应该用系统包管理器更新 Docker

求教,具体的得怎么操作???是哪些命令行?

sudo apt-get update
sudo apt-get upgrade

然后应该要重启 Docker 吧

重启 Docker 的命令是啥:smirk:

sudo apt-get upgrade后提示这个。。正常吗?

输入./launcher rebuild app
后这样了。。正常吗?要一直等吗?

要等待所有镜像下载完成。

结果这样了。。。。

FAILED

RuntimeError: su discourse -c ‘bundle config mirror.https://rubygems.org https://ruby.taobao.org/’ failed with return #<Process::Status: pid 335 exit 1>
Location of failure: /pups/lib/pups/exec_command.rb:105:in spawn' exec failed with the params {"cmd"=>["su discourse -c 'bundle config mirror.https://rubygems.org https://ruby.taobao.org/'"]} 84fe47d069a8484495bba6e8de6af138d08b12a8db545e66f199ef10b0aad220 ** FAILED TO BOOTSTRAP ** please scroll up and look for earlier error messages, there may be more than one

错误日志要滚屏到最上面,然后完整的全部拷贝下来。最后的日志没有什么信息,没有办法判断发生了什么

已经搞定。。多谢。。